Browsers Supported by Absorb

Follow

Applies to: Starter, Pro, Plus, & Enterprise Plans

As Absorb is capable of being displayed on a multitude of devices we do not have any specific system requirements. Our learner interface runs great on screens of all sizes (desktop / tablet / mobile phones), but we recommend that you limit your use of the admin interface to desktops or tablets. Here is a list of officially supported browsers compatible with Absorb LMS: 

 
chrome.png Chrome (Desktop / Tablet / Mobile) 
 
IE.png Internet Explorer 11 (Desktop / Tablet / Mobile) 
 
edge.png Edge
 
firefox.png Firefox (Desktop) 
 
safari.png Safari (macOS / iOS) 
 
  Android (Tablet / Mobile)    
 
With the exception of Internet Explorer, only the most recent versions of each browser will be officially supported by Absorb LMS. 
 
Support for Internet Explorer 9 & Internet Explorer 10 was terminated effective as of November 1, 2017
 
Keep in mind that your individual course content may have additional requirements above and beyond the browser. E.g., if you are still using Flash based courses in the Learner User Interface, then learners will need to have Flash installed. Please note that Flash support will be discontinued by all major browsers, and Adobe, by the end of 2020.
Published on
Have more questions? Submit a request

0 Comments

Article is closed for comments.